Die Excel-Funktion SUMMEWENNS für bedingtes Addieren von Werten

Eine der Funktionen, die mit der Version Excel 2007 neu in den Funktionskatalog aufgenommen wurde, ist die Funktion SUMMEWENNS. Im Gegensatz zu der Funktion SUMMEWENN können Sie mit dieser Funktion einen Zellbereich von Werten addieren unter Berücksichtigung von bis zu 127 Bedingungen.

Die Funktion ist für 2 Bedingungen folgendermaßen aufgebaut:

=SUMMEWENNS(<Zellbereich, dessen Werte addiert werden sollen>;<erster zu prüfender Bereich;<erste Bedingung>;<zweiter zu prüfender Bereich>;<zweite Bedingung>)

Die Anwendung dieser Funktion soll an dem folgenden Beispiel gezeigt werden:

In der unteren Tabelle sind die Rechnungs- und Zahlungsbeträge von Kunden erfasst worden. Die Funktion SUMMEWENNS soll verwendet werden, um flexibel die Anzahl der überfälligen Beträge eines oder aller Kunden zu einem bestimmten Stichtag zu ermitteln:

SUMMEWENNS in Excel

Die Zellen mit dem gelben Hintergrund markieren die offenen Posten, die bis zum 22.01.2011 fällig waren und noch nicht beglichen wurden.

Die Formel für die Berechnung der Summe der überfälligen Beträge des Kunden Meyer zum Stichtag 22.01.2011 in Höhe von 310,00 € lautet folgendermaßen:

=SUMMEWENNS(F2:F10;A2:A10;“Meyer“;C2:C10;“<=22.01.2011″)

Diese Formel ist wie folgt zu lesen:

Addiere die Zahlen in dem Zellbereich F2 bis F10 nur, wenn in der gleichen Zeile im Zellbereich A2 bis A10 der Kunde Meyer erscheint und im Zellbereich C2 bis C10 ein Fälligkeitsdatum kleiner oder gleich dem 22.01.2011 enthalten ist.

Um die Formel flexibel verwenden zu können, sollten Sie den Namen des Kunden oder den Stichtag nicht als Konstanten in die Formel eintragen, sondern 2 Zellbezüge verwenden, in denen die Kriterien jeweils eingetragen werden:

SUMMEWENNS in Excel

Wenn Sie in der Zelle A14 den Namen des Kunden und in Zelle B14 das Kriterium für den Stichtag eingeben, lautet die Formel für die Ermittlung der überfälligen Beträge in Zelle C14 wie folgt:

=SUMMEWENNS(F2:F10;A2:A10;A14;C2:C10;B14)

Sie können in Zelle B14 auch als Stichtag das aktuelle Tagesdatum verwenden. Geben Sie dazu in Zelle B14 die folgende Formel ein:

=“<=“ &TEXT(HEUTE();“TT.MM.JJJJ“)

Wenn Sie die überfälligen Beträge eines Kunden für Rechnungen ermitteln möchten, die in einen bestimmten Zeitraum fallen, können Sie die folgende Formel verwenden (siehe Zelle D17)

=SUMMEWENNS(F2:F10;A2:A10;A17;C2:C10;B17;C2:C10;C17)

Hinweise:

  • Falls Sie die Summe der überfälligen Beträge für alle Kunden sehen möchten, brauchen Sie in der Zelle A14 nur das Platzhalterzeichen * einzugeben.
  • Wenn Sie in der Zelle A14 den Ausdruck <>Meyer eingeben, wird die Summe aller überfälligen Beträge für die Kunden berechnet, die nicht Meyer heißen.
  • Die Anzahl der Zeilen und Spalten für den Zellbereich, der addiert werden soll, muss gleich sein der Anzahl der Zeilen und Spalten aller Kriterienbereiche. Ansonsten erscheint in der Formelzelle der Ausdruck #WERT.

Sie können hier die Beispieldatei herunterladen, um so einen besseren Zugang zu der Funktion SUMMEWENNS zu bekommen.

Michael Richter

Michael Richter

Autor

Ich unterstütze unsere Kunden in erster Linie durch Programmierung von Datenbankanwendungen und Zusatzmodulen von Microsoft Office. In Seminaren und Tipps auf unserer Blogseite gebe ich mein Wissen weiter.

41 Kommentare

  1. Super

    Antworten
  2. Ich brauchte eine Auswertung einer Tabelle nach Monat und einer Kennziffer. Z.B. wieviel Euro zu einer bestimmten Kennziffer im Monat Januar angefallen sind. Das Einbinden des Monat´s gelingt mir einfach nicht.

    Antworten
  3. topp, gutes beispiel und verständlich erklärt! ein versuch und gleich ein ergebnis, so macht excel spaß.

    Antworten
  4. Zeitersparnis 🙂

    Antworten
  5. Zeitersparnis

    Antworten
  6. warum gibt’s die Beispieldatei nur über fb ?????

    Antworten
  7. in dem Stichtag-Feld soll nur das Datum stehen, der Operator „<" oder ">“ soll in der Formel eingebaut werden. Denn es geht jeweils um den Zeitraum zwischen zwei Stichtagen, von denen es mehrere gibt. Und wenn ich die einzelnen Stichtage manuell anpasse, möchte ich nur die Stichtage einmal ändern – also immer nur „bis“, nicht zusätzlich „von“ manuell eingeben.

    Antworten
  8. Konnte den gewünschten Wert als Excel N00b berechnen. Danke!

    Antworten
  9. Zeitersparnis

    Antworten
  10. Zeitersparnis

    Antworten
  11. gut so weiter so mfg angelo

    Antworten
  12. Zeitersparnis

    Antworten
  13. Vielleicht einmal eine Probe Rechnung üben lassen und am Ende das Ergebnis zeigen, damit man weißt was man falsch gemacht hat

    Antworten
  14. Für die Bedingung würde ich gern prüfen, ob die Zeile der zu prüfenden Spalte einen Suchtext enthält.

    Antworten
  15. Beispiele zu komplex

    Antworten
  16. Das ist doch mal eine umfangreiche Erklärung!

    Antworten
  17. Perfekt! Genau was ich brauche. So gut beschrieben, dass die Anwendung auf Anhieb klappte! Danke!

    Antworten
  18. Wie funktioniert die Formel Summewenns wenn die Auswahlkriterien nur aus Zahlen besteht?

    Antworten
  19. kann man als Laie nicht nachvollziehen (wo welche Formel reinkopiert werden soll) als Profi braucht man es nicht ergo also unnötig hilfreich wäre: eine Beispieldatei oder genau erklären was wo in welche Zelle kommt.

    Antworten
  20. Ich hatte versucht, mit SUMMEWENN und Verknüpfen der Kriterien mit UND weiterzukommen. Danke für diese Seite.

    Antworten
  21. sehr gut.

    Antworten
  22. das war genau die Lösung für mein Problem. Danke

    Antworten
  23. Sie haben mir schlicht meine Frage punktgenau beantwortet.

    Antworten
  24. Zeitersparnis und Formelverständnis

    Antworten
  25. Zeitersparnis & Formelauflösung

    Antworten
  26. Hallo, funktioniert summewenbs auch wenn die Daten über ein sverweos aus einem anderen Zabellenblatt kommt? Grüße Kennedy

    Antworten
  27. Bearbeitung der Liste

    Antworten
  28. Beispiel war super klar und deutlich. Der Artikel war perfekt für mich. Danke. Zeitersparnis, weniger klicken und manuell rechnen

    Antworten
  29. elegante Lösung, die auch in Zukunft genutzt werden kann 🙂

    Antworten
  30. Sehr schön und verständlich erklärt. Ein gutes Beispiel gewählt, sehr gut. Dankeschön

    Antworten
  31. Summe aller Beträge innerhalb eines Datumbereichs wäre interessanter

    Antworten
  32. ausschreiben eines Syntax =“<=" &TEXT(HEUTE();"TT.MM.JJJJ")

    Antworten
  33. Zeitersparnis

    Antworten
  34. Die angegebene Formel ergibt #NAME?

    Antworten
  35. Gut erklärt, gerne mehr solcher Tips!

    Antworten
  36. Danke, das ist eine gute Anleitung, wenn man spontan eine Lösung zu SUMMEWENNS sucht.

    Antworten
  37. War mir sehr behilflich.

    Antworten
  38. Das gleiche mit einem anderen beispiel. Etwa dergestalt: WENN ein Feld GLEICH dem vorherigen, dann ein Feld (dieser Zeile) zumm vorherigen addieren (nicht das vergleichsfeld)!! Vielen Dank MfG d. Strüven

    Antworten
  39. Gute Erklärung, danke

    Antworten
  40. Zeitersparnis, know-how

    Antworten
  41. Hallo zusammen,
    für einen dynamischen Datumsbereich verwendet man:

    =SUMMEWENNS(F:F;C:C;“>“&J5;C:C;“<"&K5)

    J5 und K5 tragen als Zellenwert das Datum als echten Datumswert.

    Antworten

Einen Kommentar abschicken

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Pin It on Pinterest

Share This