SVERWEIS mit variabler Spaltenangabe in Excel

Mit der Funktion SVERWEIS können Sie bekanntlich in einer Tabelle nach einem Wert in einer bestimmten Spalte suchen, wenn das Suchkriterium in der ersten Spalte der Tabelle gefunden wird. In diesem Tipp möchten wir Ihnen zeigen, wie Sie die Spalte, aus der der Wert entnommen werden soll, variabel gestalten können.

In der folgenden Liste sind die Preise für
Markisen nach Breite und Farbe dargestellt:

Bild1

Durch die Kombination der Funktionen SVERWEIS
und VERGLEICH können Sie den Preis aus der Tabelle ermitteln, wenn
Sie die Breite und die Farbe in 2 verschiedenen Zellen angeben.

Die Formel zur Ermittlung des Preises in der
Zelle C14 lautet:

=SVERWEIS(A14;Preisliste;VERGLEICH(B14;Farben;0)+1;FALSCH)

Erläuterungen:

  • Mit Preisliste wurde der Zellbereich A3:E11 benannt.
  • Der Name Farben bezieht sich auf den Zellbereich B2:E2.
  • Die Funktion SVERWEIS sucht den in der
    Zelle A14 eingegebenen Wert in der ersten Spalte der Tabelle mit
    den Preisen. Mit dem Argument FALSCH wird nach einer genauen
    Übereinstimmung gesucht.
  • Mit der Funktion VERGLEICH soll die
    gewünschte Spalte ermittelt werden .Die Funktion VERGLEICH sucht
    nach der genauen Übereinstimmung der in Zelle B14 eingegebenen
    Farbe im Zellbereich B2:E2. Wenn die Farbe existiert, wird die
    Position der Farbe im angegebenen Bereich zurückgegeben. Dieser
    Wert muss noch mit 1 addiert werden, um die gewünschte Spalte in
    der Preisliste zu erhalten.
    Beispiel:
    Die Farbe gelb befindet sich an Position 3 im Zellbereich
    B2:E2. Da die Preise für die Farbe gelb in der 4. Spalte
    der Preisliste stehen, muss die ermittelte Position noch um 1
    erhöht werden.
  • In der Funktion VERGLEICH hat das 3.
    Argument den Wert 0, um nach einer genauen Übereinstimmung in
    der Liste der Farben zu suchen.
  • <p“>Falls Sie eine Breite oder Farbe angeben,
    die in der Preisliste nicht existiert, erscheint als
    Formelergebnis #NV, d. h. der Wert ist nicht vorhanden.

Hinweis:

Sie können in der Zelle B14 eine
Gültigkeitsprüfung einbauen, indem Sie nur Farben aus einer Liste
auswählen können, die sich auf den Zellbereich B2:E2 bzw. Farben
bezieht.

Bild2

Michael Richter

Michael Richter

Autor

Ich unterstütze unsere Kunden in erster Linie durch Programmierung von Datenbankanwendungen und Zusatzmodulen von Microsoft Office. In Seminaren und Tipps auf unserer Blogseite gebe ich mein Wissen weiter.

7 Kommentare

  1. Anonymous

    Danke!

    Antworten
  2. Anonymous

    Lösung für Excelauswertung super erklärt.

    Antworten
  3. Anonymous

    Verständlichkeit

    Antworten
  4. Anonymous

    Zeitersparnis und Verständis für die Zusammenhänge in der Formel. Großes Danke!

    Antworten
  5. Anonymous

    Super, hat mir sehr geholfen. Danke!

    Antworten
  6. Anonymous

    Zeitersparnis und gute graphische Darstellung; Grafik hat mir persönlich zu Erklärung gereicht

    Antworten
  7. Anonymous

    in der Funktion SVerweis+Vergleich.

    Antworten

Einen Kommentar abschicken

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Pin It on Pinterest

Share This