Letzten Einkaufspreis eines Artikels in Excel ermitteln

Wenn Sie in Excel in einer Tabelle regelmäßig die Einkaufspreise wichtiger Artikel speichern, ist oft der letzte Einkaufspreis eines ausgewählten Artikels interessant. In diesem Tipp zeigen wir Ihnen, wie Sie den letzten Einkaufspreis per Formel ermitteln.

In der folgenden Tabelle sind die Einkaufspreise diverser Artikel zu bestimmten Terminen aufgeführt:

Excel-Tabelle mit Einkaufspreisen

Die Tabelle heißt Einkauf. Sie ist sortiert nach der Spalte Einkaufsdatum. Die Art der Sortierung hat keinen Einfluss auf die spätere Anwendung der Formel. In der Zelle A17 können Sie den Artikel eingeben, dessen letzten Einkaufspreis Sie ermitteln möchten.

In der Zelle B17 wird zunächst das letzte Einkaufsdatum des ausgewählten Artikels mit der folgenden Formel ermittelt:

=MAXWENNS(Einkauf[Einkaufsdatum];Einkauf[Artikel];A17)

Die Funktion MAXWENNS ermittelt den maximalen Wert in einem Zellbereich unter der Berücksichtigung von einer oder mehreren Bedingungen. Im Funktionsassistenten sieht die Funktion folgendermaßen aus:

Excel-Funktion MAXWENNS;

Zunächst geben Sie den im Feld Max_Bereich den Zellbereich ein, aus dem der maximale Wert ermitteln werden soll. Der maximale Wert eines Datums ist das letzte Datum. In unserem Beispiel ist dies die Spalte Einkaufsdatum in der Tabelle Einkauf. Der strukturierte Verweis in der Formel lautet demnach Einkauf[Einkaufsdatum]. Als zweites Argument erwartet die Funktion den ersten Kriterienbereich, der geprüft werden soll. In unserem Beispiel ist dies die Spalte Artikel. Deshalb erscheint in der Formel als zweites Argument Einkauf[Artikel]. Als drittes Argument geben Sie im Feld Kriterien1 den Bezug zur Zelle A17 ein, in der der gesuchte Artikel steht. In der Zelle B17 steht das letzte Einkaufsdatum des Artikels Artikel 3.

Für die Bestimmung des letzten Einkaufspreises können Sie die Funktion MINWENNS verwenden. Mit ihr können Sie den kleinsten Wert in einem Zellbereich ermitteln unter der Berücksichtigung von mehreren Bedingungen. Die Formel in Zelle C17 lautet:

=MINWENNS(Einkauf[Einkaufspreis];Einkauf[Artikel];A17;Einkauf[Einkaufsdatum];B17)

In der Spalte Einkaufspreis der Tabelle Einkauf wird der letzte Einkaufspreis gesucht unter folgenden Bedingungen, die beide erfüllt sein müssen:

  • Der Artikel entspricht dem Artikel, den Sie in Zelle A17 eingetragen haben.
  • Das Einkaufsdatum ist identisch mit in der in der Zelle B17 mit Hilfe der MAXWENNS-Formel ermittelten Datum des letzten Einkaufs.

Im Funktionsassistenten gibt die Formel so aus:

Excel-Funktion MINWENNS

Ergebnis

Der letzte Einkaufspreis des Artikel Artikel 3 beträgt 17,50 €.

Hinweise

  • Die Funktion MINWENNS ermittelt den kleinsten Preis eines Artikels, falls der Artikel mehr als einmal am letzten Einkaufstag bestellt wurde, d.h. wenn es mehr als 1 Zeile in der Tabelle mit dem Artikel und dem ermittelten Datum gibt.
  • Falls Sie in der Zelle A17 einen Artikel eingeben, der in der Tabelle nicht existiert, erscheint in der Zelle B17 als Ergebnis das nichtexistierende Datum 00.01.1900. Dieses Datum wird ausgegeben, weil das Ergebnis der Formel der Wert 0 ist und dieser Wert als Datum formatiert wird. Um in diesem Fall z. B. als Ergebnis nicht vorhanden anzuzeigen, können Sie die Formel in Zelle B17 mit einer WENN-Funktion ergänzen: Im Folgenden sehen Sie zwei Varianten:
    • =WENN(MAXWENNS(Einkauf[Einkaufsdatum];Einkauf[Artikel];A17)=0;”nicht vorhanden”; MAXWENNS(Einkauf[Einkaufsdatum];Einkauf[Artikel];A17))
    • =WENN(ZÄHLENWENN(Einkauf[Artikel];A17)=0;”nicht vorhanden”; MAXWENNS(Einkauf[Einkaufsdatum];Einkauf[Artikel];A17))
  • Falls Sie in Zelle A17 das Zeichen * als Platzhalter für ein oder beliebige Zeichen eintragen, werden unabhängig von einem Artikel in Zelle B17 das letzte Einkaufsdatum und in Zelle C17 der kleinste Einkaufspreis an diesem Tag angezeigt.

Weiterer Tipp

Wenn Sie die letzten Einkaufspreise aller Artikel mit einer PivotTable ermitteln möchten, finden Sie hier einen interessanten Tipp.

Michael Richter

Michael Richter

Autor

Ich unterstütze unsere Kunden in erster Linie durch Programmierung von Datenbankanwendungen und Zusatzmodulen von Microsoft Office. In Seminaren und Tipps auf unserer Blogseite gebe ich mein Wissen weiter.

3 Kommentare

  1. Hallo

    Ich finde schon dass dies einen praktischen Wert hat:
    In meinem Beispiel bekommen wir diese Rohdaten über einen Export aus SAP

    Die Ermittlung des letzten preises ist dann nur noch eine Kleinigkeit

    *thumbsup*

    Antworten
  2. Hat diese Tabelle wirklich einen praktischen Wert? Dazu müsste man alle gekauften Artikel in einer Tabelle erfassen, der Aufwand ist riesig. Viel einfacher wäre es, in der letzten Rechnung nachzusehen. Tut wer so etwas?

    Antworten
    • Sehr geehrter Herr Kovski,

      Sie haben recht, sämtliche Daten manuell zu erfassen wäre aufwändig. Eine Liste mit Einkaufspreisen kann auch aus externen Datenquellen importiert worden sein. Die Suche nach einer Rechnung kostet auch Zeit. Ich wollte in diesem Tipp grundsätzlich zeigen, wie PivotTables genutzt werden können, um aus einer Liste für alle Einträge einer Spalte den aktuellsten Wert aus einer anderen Spalte abzulesen. Auf diese Weise können mit PivotTables auch die letzten Aufträge von Kunden oder die letzten Arbeitseinsätze von Mitarbeitern ermittelt werden. Mit der Liste mit den Einkaufspreisen können Sie zusätzlich die Preisentwicklung sowie saisonale Schwankungen erkennen.

      Antworten

Einen Kommentar abschicken

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Pin It on Pinterest

Share This